Go to TogaWare.com Home Page.
GNU/Linux Desktop Survival Guide
by Graham Williams
Google

Inco Install Log


The basic install chose the qwerty/us keyboard. The disks were partitioned as 12GB for a linux partition (hda3) and 1GB for swap (hda4). Root was mounted from /dev/hda3. The kernel was installed from CD-ROM with devices selected including fs/autofs, fs/nfs, fs/nfsd, fs/ntfs, fs/vfat, net/3c59x, misc/psaux and net/ppp. The network hostname was identified as inco. The base system was installed from CD-ROM. Configuration involved setting the timezone to Australia/ACT with the clock not set to GMT (since it is dual boot). Initially skipped the "Make Linux boot directly from hard disk", but created a boot floppy. A Cusomt Boot was chosen and the system was rebooted.

The built-in network card is eth2 when docked and eth0 when undocked. See Section 69.12 to handle this.

Install i8kutils to control the Dell Latitude CPU fan, volume buttons, and Fn-keys, and to report CPU temperature. Includes a little applet to include a CPU temperature in the Gnome-Panel. You may need to load the module i8k. (By the way, i8k stands for Insperion 8000.) The command line i8kctl lists the current status of the fans.

Lilo was configured to boot MS/Windows/2000 by pointing it to /dev/hda1. Later, lilo was replace with grub for booting.

Sound card support from the kernel required adding the following line to /etc/modules.conf (by adding it to /etc/modutils/sndconfig then running update-modules:



  alias sound-slot-0 maestro3

Refer to documentation in /usr/src/linux/Documentation/sound/ for details.

The video card has TV-Out but ATI is not supporting Linux on this yet, unlike NVidia which supports TV with its XFree86-4 option:



  Option "ConnectedMonitor" "TV".

Currently on Inco I have:

  Option "Display" "BIOS"

which tells it to use whatever the BIOS recognises as connected (either CRT or FP).

At one time I had a problem playing videos with xine. Starting xine on Inco (115.37) displayed just a blue screen, even when the video is playing. If I choose the video driver to be xshm it works acceptably. Ogle fails to start also, although mplayer coped. The problem was running with 16 rather than 24 bpp X server!

Copyright © 1995-2014 Togaware Pty Ltd
Support further development through the purchase of the PDF version of the book.
Brought to you by Togaware.