Go to TogaWare.com Home Page.
GNU/Linux Desktop Survival Guide
by Graham Williams
Google

10.10 Upgrade Failed to Boot [101206]


On upgrading to 10.10 I could not boot with the new kernel (2.6.35-22-generic). This is a known kernel bug but won't be fixed for Ubuntu 10.10 apparently. The older kernel will boot (which I was doing until eventually I installed a new version of VirtualBox and that could not compile with the old kernel because the kernel header package is no longer available for that version). The temporary patch is to add pci=nocrs to the kernel line in /boot/grub/menu/list. This will probably be overwritten next time update-grub is run.


Copyright © 1995-2014 Togaware Pty Ltd
Support further development through the purchase of the PDF version of the book.
Brought to you by Togaware.